golem: A Framework for Robust Shiny Applications

An opinionated framework for building a production-ready 'Shiny' application. This package contains a series of tools for building a robust 'Shiny' application from start to finish.

Version: 0.3.1
Depends: R (≥ 3.0)
Imports: attempt (≥ 0.3.0), cli, config, crayon, desc, dockerfiler, fs, here, htmltools, jsonlite, pkgload, remotes, rlang, roxygen2, rstudioapi, shiny (≥ 1.5.0), testthat, usethis, utils, yaml
Suggests: covr, devtools, glue, knitr, pkgdown, purrr, rcmdcheck, rmarkdown, spelling, stringr, tools, withr, pkgbuild, processx, rsconnect
Published: 2021-04-17
Author: Colin Fay ORCID iD [cre, aut], Vincent Guyader ORCID iD [aut] (previous maintainer), S├ębastien Rochette ORCID iD [aut], Cervan Girard ORCID iD [aut], Novica Nakov [ctb], David Granjon [ctb], ThinkR [cph]
Maintainer: Colin Fay <contact at colinfay.me>
BugReports: https://github.com/ThinkR-open/golem/issues
License: MIT + file LICENSE
URL: https://github.com/ThinkR-open/golem
NeedsCompilation: no
Language: en-US
Materials: README NEWS
CRAN checks: golem results

Downloads:

Reference manual: golem.pdf
Vignettes: a_start
b_dev
c_deploy
d_js
config
f_extending_golem
e_golem_cheatsheet
Package source: golem_0.3.1.tar.gz
Windows binaries: r-devel: golem_0.3.1.zip, r-release: golem_0.3.1.zip, r-oldrel: golem_0.3.1.zip
macOS binaries: r-release (arm64): golem_0.3.1.tgz, r-release (x86_64): golem_0.3.1.tgz, r-oldrel: golem_0.3.1.tgz
Old sources: golem archive

Reverse dependencies:

Reverse imports: apisensr, babsim.hospital, dccvalidator, discoveR, dragon, FielDHub, gwpcormapper, InterCellar, multiSight, regexTestR, ReviewR, spatialLIBD, wpm
Reverse suggests: bs4Dash, packer

Linking:

Please use the canonical form https://CRAN.R-project.org/package=golem to link to this page.