Require: Installing and Loading R Packages for Reproducible Workflows

A single key function, 'Require' that wraps 'install.packages', 'remotes::install_github', 'versions::install.versions', and 'base::require' that allows for reproducible workflows. As with other functions in a reproducible workflow, this package emphasizes functions that return the same result whether it is the first or subsequent times running the function.

Version: 0.0.4
Depends: R (≥ 3.5)
Imports: data.table (≥ 1.10.4), methods, remotes, utils
Suggests: testit
Published: 2020-06-05
Author: Eliot J B McIntire ORCID iD [aut, cre], Her Majesty the Queen in Right of Canada, as represented by the Minister of Natural Resources Canada [cph]
Maintainer: Eliot J B McIntire <eliot.mcintire at canada.ca>
BugReports: https://github.com/PredictiveEcology/Require/issues
License: GPL-3
URL: https://Require.predictiveecology.org, https://github.com/PredictiveEcology/Require
NeedsCompilation: no
Language: en-CA
Materials: README NEWS
CRAN checks: Require results

Downloads:

Reference manual: Require.pdf
Package source: Require_0.0.4.tar.gz
Windows binaries: r-devel: Require_0.0.4.zip, r-release: Require_0.0.4.zip, r-oldrel: Require_0.0.4.zip
macOS binaries: r-release: Require_0.0.4.tgz, r-oldrel: not available

Linking:

Please use the canonical form https://CRAN.R-project.org/package=Require to link to this page.